Ticket #61 (closed defect: fixed)

Opened 9 years ago

Last modified 9 years ago

ERROR: value too long for type character varying(255) on EzproxyAuthenticationEvent

Reported by: https://sid.kent.ac.uk/shibboleth!https://iam.cf.ac.uk/sp/shibboleth!zvh7tlm4lp9+gcgbtxeqnb6ldtw= Owned by: smartp@…
Priority: major Milestone: v1.0.0
Component: Raptor MUA Version: v0.2.1
Keywords: Cc:

Description

error from mua log:

ERROR 2011-11-07 09:01:51,994 (o.h.u.JDBCExceptionReporter:78) ---> Batch entry 8 insert into EzproxyAuthenticationEvent (eventtime, serviceHost, resourceHost, serviceId, resourceId, eventId, eventType, resourceIdCategory, entityId, serviceName, organisationName, authenticationType, principalName, school, affiliation, requesterIp, sessionId, current_hashCode, persistantId) values ('2011-07-31 16:56:32.000000 +00:00:00', 'https://www.jstor.org/action/showLogin?redirectUri=%2Fstable%2F778224%3F%26Search%3Dyes%26searchText%3Dwood%26searchText%3Dsculpture%252C%26searchText%3Dmaterials%252C%26list%3Dhide%26searchUri%3D%252Faction%252FdoBasicResults%253Fhp%253D100%2526la%253D%2526so%253Drel%2526wc%253Don%2526acc%253Don%2526gw%253Djtx%2526jcpsi%253D1%2526artsi%253D1%2526Query%253Dsculpture%25252C%252Bmaterials%25252C%252Bwood%2526sbq%253Dsculpture%25252C%252Bmaterials%25252C%252Bwood%2526prq%253Dsculpture%25252C%252Bwood%2526si%253D101%2526jtxsi%253D101%26prevSearch%3D%26item%3D113%26ttl%3D8037%26returnArticleService%3DshowFullText', NULL, NULL, 'https://www.jstor.org', '980319689', NULL, '2', NULL, NULL, NULL, NULL, 'gw62', NULL, NULL, '92.20.127.34', '-', '-1946754762', '213886') was aborted.  Call getNextException to see the cause.
ERROR 2011-11-07 09:01:51,998 (o.h.u.JDBCExceptionReporter:78) ---> ERROR: value too long for type character varying(255)
ERROR 2011-11-07 09:01:52,004 (o.h.e.d.AbstractFlushingEventListener:301) ---> Could not synchronize database state with session
org.hibernate.exception.DataException: could not insert: [uk.ac.cardiff.model.event.EzproxyAuthenticationEvent]
        at org.hibernate.exception.SQLStateConverter.convert(SQLStateConverter.java:77) ~[hibernate-3.2.6.ga.jar:3.2.6.ga]
        at org.hibernate.exception.JDBCExceptionHelper.convert(JDBCExceptionHelper.java:43) ~[hibernate-3.2.6.ga.jar:3.2.6.ga]
        at org.hibernate.persister.entity.AbstractEntityPersister.insert(AbstractEntityPersister.java:2272) ~[hibernate-3.2.6.ga.jar:3.2.6.ga]
        at org.hibernate.persister.entity.AbstractEntityPersister.insert(AbstractEntityPersister.java:2665) ~[hibernate-3.2.6.ga.jar:3.2.6.ga]
...
        at org.quartz.simpl.SimpleThreadPool$WorkerThread.run(SimpleThreadPool.java:549) [quartz-1.8.4.jar:na]
Caused by: java.sql.BatchUpdateException: Batch entry 8 insert into EzproxyAuthenticationEvent (eventtime, serviceHost, resourceHost, serviceId, resourceId, eventId, eventType, resourceIdCategory, entityId, serviceName, organisationName, authenticationType, principalName, school, affiliation, requesterIp, sessionId, current_hashCode, persistantId) values ('2011-07-31 16:56:32.000000 +00:00:00', 'https://www.jstor.org/action/showLogin?redirectUri=%2Fstable%2F778224%3F%26Search%3Dyes%26searchText%3Dwood%26searchText%3Dsculpture%252C%26searchText%3Dmaterials%252C%26list%3Dhide%26searchUri%3D%252Faction%252FdoBasicResults%253Fhp%253D100%2526la%253D%2526so%253Drel%2526wc%253Don%2526acc%253Don%2526gw%253Djtx%2526jcpsi%253D1%2526artsi%253D1%2526Query%253Dsculpture%25252C%252Bmaterials%25252C%252Bwood%2526sbq%253Dsculpture%25252C%252Bmaterials%25252C%252Bwood%2526prq%253Dsculpture%25252C%252Bwood%2526si%253D101%2526jtxsi%253D101%26prevSearch%3D%26item%3D113%26ttl%3D8037%26returnArticleService%3DshowFullText', NULL, NULL, 'https://www.jstor.org', '980319689', NULL, '2', NULL, NULL, NULL, NULL, 'gw62', NULL, NULL, '92.20.127.34', '-', '-1946754762', '213886') was aborted.  Call getNextException to see the cause.
        at org.postgresql.jdbc2.AbstractJdbc2Statement$BatchResultHandler.handleError(AbstractJdbc2Statement.java:2586) ~[postgresql-8.4-702.jdbc4.jar:na]
        at org.postgresql.core.v3.QueryExecutorImpl.processResults(QueryExecutorImpl.java:1811) ~[postgresql-8.4-702.jdbc4.jar:na]
        at org.postgresql.core.v3.QueryExecutorImpl.execute(QueryExecutorImpl.java:407) ~[postgresql-8.4-702.jdbc4.jar:na]
        at org.postgresql.jdbc2.AbstractJdbc2Statement.executeBatch(AbstractJdbc2Statement.java:2725) ~[postgresql-8.4-702.jdbc4.jar:na]
        at com.mchange.v2.c3p0.impl.NewProxyPreparedStatement.executeBatch(NewProxyPreparedStatement.java:1723) ~[c3p0-0.9.1.2.jar:0.9.1.2]
        at org.hibernate.jdbc.BatchingBatcher.doExecuteBatch(BatchingBatcher.java:48) ~[hibernate-3.2.6.ga.jar:3.2.6.ga]
        at org.hibernate.jdbc.BatchingBatcher.addToBatch(BatchingBatcher.java:34) ~[hibernate-3.2.6.ga.jar:3.2.6.ga]
        at org.hibernate.persister.entity.AbstractEntityPersister.insert(AbstractEntityPersister.java:2252) ~[hibernate-3.2.6.ga.jar:3.2.6.ga]
        ... 26 common frames omitted
ERROR 2011-11-07 09:01:52,007 (u.a.c.r.s.StorageEngine:98) ---> Could not store events for transaction id [52887], {}

Current schema for this table:

raptor=# \d ezproxyauthenticationevent
          Table "public.ezproxyauthenticationevent"
       Column       |            Type             | Modifiers 
--------------------+-----------------------------+-----------
 persistantid       | bigint                      | not null
 eventtime          | timestamp without time zone | 
 servicehost        | character varying(255)      | 
 resourcehost       | character varying(255)      | 
 serviceid          | character varying(255)      | 
 resourceid         | character varying(255)      | 
 eventid            | integer                     | not null
 eventtype          | character varying(255)      | 
 resourceidcategory | integer                     | 
 entityid           | character varying(255)      | 
 servicename        | character varying(255)      | 
 organisationname   | character varying(255)      | 
 authenticationtype | character varying(255)      | 
 principalname      | character varying(255)      | 
 school             | character varying(255)      | 
 affiliation        | character varying(255)      | 
 requesterip        | character varying(255)      | 
 sessionid          | character varying(255)      | 
 current_hashcode   | integer                     | 
Indexes:
    "ezproxyauthenticationevent_pkey" PRIMARY KEY, btree (persistantid)

Change History

comment:1 Changed 9 years ago by smith@…

  • Owner changed from Rhys Smith to smartp@…
  • Status changed from new to assigned
  • Version set to v0.2.1
  • Component changed from Distribution - RPM to Raptor MUA
  • Milestone set to v0.3.0

comment:2 Changed 9 years ago by smith@…

  • Milestone changed from v0.3.0 - (int only) to v1.0.0

comment:3 Changed 9 years ago by smartp@…

  • Status changed from assigned to accepted

comment:4 Changed 9 years ago by smartp@…

  • Status changed from accepted to closed
  • Resolution set to fixed

increase default size of the serviceHost column to 400 characters. However, I am not entirely sure Raptor has parsed that line correctly. This should work, but needs looking at in the future.

Note: See TracTickets for help on using tickets.