Ticket #166 (closed defect: wontfix)

Opened 7 years ago

Last modified 6 years ago

RPMs insist on java 1.6

Reported by: smith@… Owned by: smith@…
Priority: major Milestone: v1.2.0
Component: Distribution - RPM Version: v1.1.4
Keywords: Cc:

Description

If you have java 1.7 (e.g. java-1.7.0-openjdk) installed, yum insists on installing 1.6 anyway. Currently the spec file specifies java >=1.6.0 as a prerequisite. Need to fix this as it works fine on 1.7.

Note that we should not *require* 1.7, it should require java >= 1.6, i.e. 1.6 OR 1.7 is fine.

Change History

comment:1 Changed 7 years ago by smith@…

Maybe just get rid of a version requirement - just require java?

comment:2 Changed 7 years ago by smith@…

Or looking around, it might be a problem with java >= 1.6.0 - java >= 1.6 might work better. Will try that.

comment:3 Changed 6 years ago by smith@…

  • Status changed from new to closed
  • Resolution set to wontfix

java 1.7.0 doesn't provide java or jre (instead java7 or jre7) as it's a tech preview in fedora. Apparently 1.7.0 will provide java/jre in the future. So will leave as is and let time solve this one...

Note: See TracTickets for help on using tickets.